Skip site navigation (1) Skip section navigation (2)

Site Navigation

FreeBSD/sparc64 Project

Introduction

This page contains information about the FreeBSD port to Sun Microsystem's UltraSPARC® architecture. UltraSPARC is a Tier 1 architecture, and as such is fully supported by the FreeBSD project. However, the port is not as mature as the existing i386 or amd64 ports. Discussion of the UltraSPARC port takes place on the freebsd-sparc mailing list.

Table Of Contents

Credits

The following people have been working either in the spotlights or behind the scenes to get the FreeBSD port off the ground:

Latest News

  • 25 October, 2004 : The CS4231 audio driver has been ported from OpenBSD, so SBus workstations equipped with sound hardware (Ultra 1E, Ultra 2) get sound support.

  • 9 October, 2004 : The auxio driver has been ported from NetBSD.

  • 10 June, 2004 : The esp driver has been imported from NetBSD, so the Ultra 1E and Ultra 2 machines get SCSI support now.

  • 18 January, 2003 : The if_xl driver is now supported in -CURRENT.

  • 10 December, 2002 : Daily snapshots of 5.0-CURRENT are now available on ftp2.FreeBSD.org.

Hardware List

A summary of supported systems follows. SMP is supported on all supported systems that contain more than 1 processor. For full details please see the release notes of the release you are using.

  • Blade 100
  • Blade 150
  • Enterprise 220R
  • Enterprise 250
  • Enterprise 420R
  • Enterprise 450
  • Fire V100
  • Fire V120
  • Netra™ T1 105
  • Netra T1 AC200/DC200
  • Netra t 1100
  • Netra t 1120
  • Netra t 1125
  • Netra t 1400/1405
  • Netra 120
  • Netra X1
  • SPARCEngine® Ultra Axi
  • SPARCEngine Ultra AXmp
  • Ultra 1E
  • Ultra 2
  • Ultra™ 5
  • Ultra 10
  • Ultra 30
  • Ultra 60
  • Ultra 80

The following systems are supported, but can only be netbooted due to the onboard SCSI controller being unsupported. Work is underway to add support for this SCSI controller. These systems may work with the esp driver imported from NetBSD.

  • Enterprise 3500
  • Enterprise 4500

The following systems are unsupported.

  • Any system with an UltraSPARC III or greater processor.
  • Ultra 1

Any system not listed here that does not have an UltraSPARC III or greater processor is expected to work, but may not have been tested. If you have a system that is not listed here please try it, and let us know about it.

What Needs To Be Done

  • Update this webpage more often.

Pointers Of Interest